
pro Fit 6.2 
A Guided Tour

This is a quick introduction to pro Fit. It gives a step by step description of a simple session with pro Fit and shows you 
some of the application's features.

Installation

Simply double-click the pro Fit disk-image. Open the disk-image and drag the pro Fit folder to a suitable place on your 
hard disk, e.g. the systems ‘Applications’ folder.

First steps

In the following we describe a typical session with pro Fit. 
We plot and analyze the growth of the world’s population 
over the last 50 years. The table below shows the number 
of inhabitants on this planet in the years since 1940.

To enter this data, you have to open a new data window:

•	

 Choose “New Data” from the File menu.
An empty data window appears.
The data is arranged in horizontal rows and vertical columns. 
The topmost cell of each column shows the name of the column 
(by default “Column 1”, “Column 2”, etc.). The cells below 
contain the data of each column.

Now you must enter the data into this window:

•	

 Click on the first empty cell of column 1 and enter the first year, 1940.
We fill the first column with the years and the second column with the population in millions. The first year is 1940.

•	

 Click on the first cell of column 2 and enter the population, 2200.
Note that we enter the population in millions.

•	

 Repeat steps 2 and 3 to enter the remaining data in the following rows.
Fill in the year and population data as given in the table above. Note that you can use the arrow keys, the tabulator key, 
and the return and enter keys to move from one cell to another.

•	

 Enter the column titles, ‘year’ and ‘population in mio’.
Click the column titles ‘Column 1’ or ‘Column 2’ and enter the new names. Double-click the column number above the 
titles to change the column format. Drag the line between the columns to adjust their width. Your window should now be 
similar to the one on the right. 

year population in millions
1940 2200
1950 2557
1960 3041
1969 3633
1975 4084
1981 4523
1987 5013
1990 5274
2000 6073
2005 6451
2009 6800



Now that you have entered the data, you can display it graphically: 

•	

 Choose “Data y(x)...” from the Plot menu.
The following dialog box appears.

In this dialog box you can enter the range of the plot, the columns to be plotted and some other options. In this 
introductory session we can use the settings as they are.

•	

 Click OK.
A drawing window appears, showing a graph of the data.

Now you can edit this graph by using some of pro Fit’s drawing features.



•	

 Double-click the vertical axis to change its range.
(Double-click the vertical axis itself, not the numbers to the left of it!) A dialog box appears, presenting options for the 
axis.

You can change a variety of options here. Most often you will use the edit fields “First” and “Last”. They define the range 
of the axis. Another important field is the “Distance” field that defines the distance between major ticks.

•	

 Enter 0 for “First” and 8000 for “Last”, then click OK.
The vertical axis of the graph starts now with 0 and ends with 8000.

Double-click other parts of the graph or its legend to see other dialog boxes, where you can change more attributes. Try 
double-clicking the horizontal axis, the centre of the plot, or the dot in the legend. You can also double-click any text in the 
drawing to change it. Or you choose any of the drawing tools at the left border of the window to add lines, polygons, etc.



Finding a mathematical model to describe the evolution of the population.

The growth of a population can often be described by an exponential function of the type

where p(t ) is the population at time t, p(x0) the population at an arbitrary start time x0, and t0 its growth constant.
Let us try to investigate the validity of this formula for the world's population. We want to find the set of parameters for 
equation (1) that describes our data best. 

•	

 Choose “Exp” from the Func menu.
The Parameters-window comes to the front. This window gives a description of the built-in exponential function and its 
parameters.

The function looks like this:

This formula is substantially identical to Eq. (1).
The Parameters-window displays the default values for A, x0, t0, and const. Starting from these values, pro Fit will look for 
a better set of parameters for describing the data. But first you must define which parameters you want to fit (i.e. to vary) 
and choose good starting values.
As mentioned above, the starting time x0 is arbitrary. Let us set it to 1940:

•	

 Click the number beside “x0” in the Parameters-window and enter the starting value 1940.
This defines the parameter's value.
Since x0 is arbitrary, we do not want to fit it:

•	

 Uncheck “Use for fitting”.
(The check box “Use for fitting” can be found in the lower right area of the window.) The parameter name changes from 
bold face to plain text. This indicates that this parameter is constant and will not be fitted.
Shortcut: You can also toggle the option “Use for fitting” by simply clicking on a parameter’s name.
We also hold the constant const fixed at 0, since we don’t need it:

•	

 Click the parameter name “const”.
Again, the text changes from bold to normal and the option “Use for fitting” is unchecked to indicate that the 
corresponding parameter will not be fitted.
Before fitting, you should assign starting values (guesses) to the parameters that are going to be fitted, in our case A and t0. 
This makes the calculations faster and improves the chances to find the best set of parameters. Reasonable starting values 
for our problem can be estimated easily:
A is the population in the year 1940, so we can set it to 2200 millions. –t0 (note the minus, it comes from the different 
definitions of Equations (1) and (2)) is the time in which the population increases by a factor e = 2.71. Looking at the plot 
of the data in the drawing window, we can easily guess it to be between 50 and 200 years. Let us set t0 to –100 (the minus 
sign comes from the differing definitions of Eqs. (1) and (2)):

•	

 Enter the starting values 2200 for A and –100 for t0.
The resulting parameters-window should now look like this:



Now we are ready to fit our parameters.

•	

 Choose “Fit...” from the Calc menu.
You see a dialog box where you can choose the data to fit:

The window shows the current data set and the current function. If you change any function parameter, the curve will 
change to reflect the new value. The window always shows a plot corresponding to the current function and data points, 
the same as the Preview window discussed below. 
As you see, our first guess for the function parameters was not altogether bad, but the function doesn’t grow as fast as the 
actual data. To get the best parameters, let’s fit now:



•	

 Click the button ‘Fit’ to start fitting
The fitted parameters are printed in the Results-window:

The fit yields –54 years for t0 and 2113 millions for  parameter A.
To see the a graphical result of the fit, have a look at the preview in the window:

If no more fits are to be done right now, you may close the fitting window.

Now we can plot the fitted function in the drawing window:



•	

 Choose “Function f(x)...” from the Plot menu
A dialog box appears, displaying some plotting options:

•	

 Click OK to draw the curve.
The curve is drawn in the graph. You can now ungroup (contextual menu on selected item) and rearrange the items in the 
drawing window to obtain a representation of data and theory like this one:



The preview window

The preview window provides a unique, interactive tool for editing and viewing functions and data. To see the Preview 
window, choose Preview from the Windows menu.
The window shows the current data set and the current function. If you change any function parameter, the curve will 
change to reflect the new value. The window always shows a plot corresponding to the current function and data points. 

To the left of the window there are some controls that let you determine what the window must show, and if it must be a 
floating window or a normal window. To the right are some tools that can be used to edit and analyze the function and the 
data.

The tools on its right side provide the following features:
•	

 Arrow tool: selecting or changing data. To change data, first select the desired data, then click & drag it.
•	

 Hand tool: moving the area to be viewed
•	

 Lens tool: zooming in and out (to zoom out, hold down the shift key)
•	

 Fitting tool: changing parameters. Simply click on a function’s curve and drag it to vary a parameter. 

(Note: The fitting tool is disabled when you have checked “Fitted params” in the Preview window.)
•	

 Marker tool: placing markers on data and functions



Defining your own functions

In the above session you fitted the built-in exponential function to your data set.  
However, what do you do if your model function is some lengthy, complicated mathematical construction that does not 
appear among pro Fit’s built-in functions in the “Func” menu?
Define your own function! In pro Fit you can define virtually any function using a Pascal-like syntax. Let’s look at an 
example:
Imagine you want to analyse a function of the form

	

y  =  a1 sin(x) × ln(x)  + a2

with the parameters a1 and a2. 

To define it in pro Fit:

•	

 Choose “New Function” from the File menu.
This opens a new, empty function window.

•	

 Enter the function in the new window.
Enter the following text:

 

a[1]*sin(x)*ln(x) + a[2]

•	

 Click the "To Menu" button in the top left corner of the function window, or choose “Compile & Add To Menu” 
from the Customize menu.

The new function is added to the Func menu, and the parameter window shows its default parameters a[1], a[2]. At the 
same time pro Fit converts your function into a full Pascal definition:
! function User_Function;
! begin
! ! y := a[1]*sin(x)*ln(x) + a[2];
! end;

To view your function, you first should set its parameters a[1] and a[2] to reasonable values, e.g. 1 and 0.5: Edit the fields 
of the parameter-window. Then bring the Preview window to front and check “Show function”. Alternatively, you can 
choose “Plot Function...” from the Draw menu for creating a plot of your function in the drawing window. (If you still 
have an open drawing-window from previous work, you should check the option “Open New Window” in the dialog box, 
or your curve will be drawn in the old graph.)

Our sample function is not defined for x<=0. If you would calculate it for a negative x-value, pro Fit would report an error. 
However, the function converges to y=a[2] for x=0. 
You may want to expand its definition range by defining y(x) = a[2] for all negative or zero x. This can be done easily by 
the following modified definition:
function User_Function;
begin
! if x <= 0
!  then y := a[2]
!  else y := a[1]*sin(x)*ln(x) + a[2];
end;

(After having modified the definition in the Function-window, again choose “Compile & Add to Menu” from the 
Customize menu to add the modified function to pro Fit.)
This new version of the function shows how you can use the if statement for conditional execution.
Your function can even be much more complicated than that. pro Fit allows function definitions that contain more than one 
statement. You also can define your own variables and procedures, you can access the data in the data windows, and much 
more. You can use most elements of the “Pascal” programming language.
In your demo package you can find various examples of function definitions.



Defining your own programs (scripting)

Besides defining functions for fitting and plotting, you can also define any algorithm for data-generation and -
transformation.
Let us have a quick look at a small program that fills the first column of a data window with the powers of two:  2, 4, 8, 16, 
etc. To define this program, again open a new Function-window (“New Function” from the file menu) and enter the 
following definition. (Note that this program starts with the keyword program, and not function. The rest of it 
follows the same syntax scheme as a function definition.)

program PowersOf2;
var i: integer;
begin
  NewDataWindow;
  for i := 1 to nrRows do
     data[i,1] := 2 ** i;
! SetColumnProperties(col 1,name 'Powers');
end;

 

To add this program to pro Fit, again choose “Compile & Add to Menu” from the Prog menu. The program “PowersOf2” 
is appended to the “Prog” menu. To start it, choose it from this menu.
There is much more that you can do with functions and programs in pro Fit. You can e. g. draw from a program, you can 
integrate functions or find their roots, you can access fitting results, open and close files, etc.
For a complete list of syntax elements for writing functions and programs, you can consult pro Fit’s on-line programming 
help. Click on the question mark at the top of the function window or choose “pro Fit Programming” from the Apple 
Guide menu. There is also a pop-up menu titled “Help” that brings up a list of all built-in functions and procedures.
To get the definition of a particular call, such as NewDataWindow, double-click it while holding down the option key – 
pro Fit will automatically open an Apple Guide window with the corresponding definition.

Getting help

pro Fit provides a powerful on-line help system based on Apple’s Help Viewer. To use it, you must have installed Help 
Viewer on your system. Apple Guide is a standard extension on System 9 or later but can also be installed on earlier 
systems.
To invoke the on-line help, choose “pro Fit Guide” from the “Help” menu. You can also invoke the help system from most 
dialog boxes and windows by clicking the question mark icon – this takes you directly to a panel that describes the 
corresponding window/dialog box.

Printing
pro Fit was designed for optimum quality results on every printer. For high-end laser writers PostScript® commands can be 
generated.  For all other printers (such as high-resolution ink-jet printers), printing occurs at maximum available 
resolution.
Therefore, to get best results, you should tell pro  Fit if you are using a PostScript printer or not. To do this, choose 
“Preferences...” from the File menu. In the dialog box that appears, click the icon “Printing”. In the corresponding panel,  
you should check or uncheck the check-box “Print drawings using PostScript”.



Exporting graphics
When you are working with a drawing application such as pro Fit, you may want to copy drawings from this application 
into your word-processor.
There are two possibilities to do that:
1.	

 Copy the desired part of a drawing from pro Fit and paste it into your word processor (or use drag & drop).
2.	

 If you are going to print on a PostScript printer, you can save your drawing as a PostScript- (EPS) file (if your text 

application supports this feature).

Depending on the features of your word-processor you may want to define what is included in the copied images in order 
to achieve best printing quality.
To set the desired option, choose “Preferences...” from the File menu and click the icon “Copy”:

Here you can specify if you want to include a PDF file or a Quickdraw PICT including a bitmap into the images that you 
copy from pro Fit. For the bitmap images you can select the desired resolution in dots per inch.

Besides that you may want to export pro Fit images into different type image files, such as EPS, PICT, PDF, TIFF, PNG, 
GIF, and JPEG. Choose “Export…” from the File menu and set the desired options for export.
Below as an example, the options for JPEG file export:



More
Graphs are embedded in a general drawing editor:
Have you already added some drawing or text labels to your plots in the Drawing-window? If not, then open a drawing 
window, select any drawing tool (e.g. the “A” in the toolbox at the left border of the window), and click into the drawing 
window. If you selected the  “A”, a dialog box will allow you to interactively create a text label with any font, size, style, 
and arbitrary sub- and superscripts.
External modules:
If you should ever think that you have reached the limits of pro Fit:
You may have noticed the command “Load Modules...” in the Customize menu. 
With this command, you can add the code of a function or program that you have written in any compiler of yours, and use 
it in the same way as any built-in function or program.
If you are used to programming your own code for data or function analysis, you can consider pro Fit as a big library 
offering routines for numeric analysis, data input/output and high resolution graphics output.
The pro  Fit demo package includes some code and source examples of external functions and programs in the folder 
“External Modules”.
Contour plotting, 3D-plotting, histograms, polar plots, etc.
pro Fit comes with external modules for 3D-plotting, contour plotting, pie charts, polar plots, vector plots and more. To 
use these modules, you must link them to pro Fit: Choose “Load Module...” from the Prog menu and select the desired 
module. It is added to the Prog menu. (Note: The 3D-plotting module requires OpenGL.)
And more...:
As you work with pro Fit, you will discover many other unique features. Have a look at the files that come with the demo 
package. Explore!

Contact
To get more information on pro Fit, have a look at

http://www.quansoft.com

If you have questions, please contact us via email
profit@quansoft.com
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